Luego de que el 7 de abril de 2014 se descubriera una de las vulnerabilidades más graves de los últimos años que afectó a millones de servidores Web GNU/Linux (aparentemente un tercio de los servidores de Internet) debido a un fallo en la implementación de TLS en ciertas versiones de OpenSSL, algunos fanboys de Apple salieron a festejar la prueba irrefutable de que el software libre no es seguro en absoluto (¿?).

Muchas personas tienen ciertos intereses, probablemente económicos, en afirmar que el software de código cerrado es más seguro que el software de código abierto. Por muchas razones (principalmente auditabilidad) pienso lo contrario. Y personalmente sigo pensando que los sistemas GNU/Linux son los más seguros que existen (después de BSD). Pero esto es una mera opinión personal, y no voy a abordar una discusión en este artículo acerca de qué sistema operativo es el más seguro.

Lo que me motiva a escribir este artículo es la estupidez de ciertos Apple fanboys. Aquellos sujetos que salieron a festejar en Twitter y otras redes sociales la vulnerabilidad que afectó a los sistemas GNU/Linux, sin darse cuenta que Twitter funciona bajo Linux y que, si sus servidores hubieran sido vulnerables, ¡sus cuentas de usuario podrían haber sido robadas!

En fin, hay mucha gente resentida que odia a GNU/Linux y el software libre en general. Yo nunca he criticado a Apple, Microsoft, o cualquier otra empresa de software propietario en este blog, ni lo haré ahora, simplemente les voy a dedicar este pequeño artículo a aquellos Linux-haters. Si odiás Linux no podés usar... casi ningún servicio en Internet. Porque en definitiva ¿quién usa algo que odia? Los masoquistas supongo.



La vulnerabilidad en cuestión fue encontrada por un investigador de Google en OpenSSL 1.0.1. La misma permitiría a un atacante obtener 64Kb de memoria. Los resultados son escalofriantes dado que en dicha sección de memoria se podrían encontrar credenciales, cookies de sesión, claves privadas, etc., de los clientes conectados al servidor vulnerable.

Lo reconozco, fue una vulnerabilidad grave, pero probablemente nunca fue explotada hasta el momento de ser descubierta. Aunque lo más bizarro de todo es que ¡¡¡Mac OS X usa OpenSSL al igual que GNU/Linux!!!

Pero bueno, los iDiots son así.

Por ello, para ayudarlos a no caer en un sistema vulnerable, les voy a dejar una lista de aquellos sitios en Internet que no pueden visitar si odian Linux:

  • Google
  • Facebook
  • YouTube
  • Yahoo!
  • Blogger
  • Baidu
  • Wikipedia
  • Twitter
  • QQ
  • LinkedIn
  • Wordpress
  • Mozilla
  • Flickr
  • Paypal
  • Craigslist
  • Ask
  • CNN
  • Tumblr
  • LiveJournal
  • eHow
  • Stackoverflow
  • FoxNews
  • Y la lista sigue...

Moraleja: si odiás a Linux, odiás a Internet.

No odies a GNU/Linux, Windows o Apple por culpa de sus usuarios. Yo no odio a Apple, sólo a sus fanboys :)

Fuentes

Top Web Sites Running Linux

List of Linux adopters

Netcraft - Monitoring Services

Alexa - The top 500 sites on the web


Tal vez pueda interesarte


Compartí este artículo