En este artículo voy a demostrar, utilizando un pequeño video, cómo habilitar el soporte extendido (LTS, long term support) en sistemas Debian 6.

Como muchos sabrán, el grupo de desarrollo de Debian ha decidido extender el soporte para Debian 6 hasta febrero de 2016. Aunque el soporte será únicamente para actualizaciones de seguridad y estará soportado por un grupo de voluntarios y empresas interesadas, no por el equipo de seguridad de Debian. Esta es la primera vez que Debian ofrece una versión LTS (long term support).

El soporte extendido no se encuentra habilitado por defecto en Debian 6 ya que es una característica nueva, soportada por terceros, que ha surgido justo antes de finalizar su soporte oficial. Para poder utilizar el soporte extendido (LTS), y beneficiarse con las actualizaciones de seguridad, sólo es necesario agregar el repositorio squeeze-lts en la configuración del gestor de paquetes APT.

Agregar las siguientes líneas en el archivo /etc/apt/sources.list:

deb http://http.debian.net/debian squeeze-lts main contrib non-free
deb-src http://http.debian.net/debian squeeze-lts main contrib non-free

Cabe destacar que para que el repositorio LTS funcione, es necesario habilitar los repositorios squeeze y squeeze security. Por lo tanto, la configuración de repositorios de APT debe contener:

deb http://http.debian.net/debian/ squeeze main contrib non-free
deb-src http://http.debian.net/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://http.debian.net/debian squeeze-lts main contrib non-free
deb-src http://http.debian.net/debian squeeze-lts main contrib non-free

A modo de ejmplo, voy a utilizar un servidor LAMP (Linux+Apache+MySQL+PHP). Antes de habilitar el repositorio LTS y actualizar, el servidor utiliza el kernel Linux 2.6.32 liberado el 13 de mayo:

root@debian6:~# uname -a
Linux debian6 2.6.32-5-amd64 #1 SMP Tue May 13 16:34:35 UTC 2014 x86_64 GNU/Linux

A continuación el video: configuración del repositorio LTS y actualización:

Al finalizar la actualización (y luego de reiniciar) el servidor posee el kernel Linux 2.6.32 liberado el 12 de julio:

root@debian6:~# uname -a
Linux debian6 2.6.32-5-amd64 #1 SMP Sat Jul 12 16:47:57 UTC 2014 x86_64 GNU/Linux

A pesar de que gracias a este repositorio Debian 6 tendrá actualizaciones de seguridad hasta febrero de 2016, se recomienda migrar a la versión estable actual: Debian 7.

Fuente: Using Debian squeeze (6.0) LTS


Tal vez pueda interesarte


Compartí este artículo